Access Denied. No Sufficient Permissions (code 2408)

Access Denied. No Sufficient Permissions (code 2408)

Acceso denegado. Sin permisos suficientes (código 2408)

Situación

Un plan de respaldo finaliza con el siguiente error: Access Denied. No Sufficient Permissions

Los siguientes registros se encuentran en el registro de eventos: Error del servicio de instantáneas de volumen: error inesperado al consultar la interfaz IVssWriterCallback. hora = %1. Esto a menudo se debe a una configuración de seguridad incorrecta en el proceso del escritor o del solicitante. %2

Causa

El código de error 8194 es un error de "Acceso denegado" causado por la incapacidad de uno o más escritores del sistema VSS para comunicarse mediante las llamadas "COM" expuestas en la interfaz IVssWriterCallback (interfaz de programación de Microsoft para Volume Shadow Service).

Solución

Hay dos formas de resolver el problema:

Tenga en cuenta que puede ser necesario reiniciar

  • La primera forma (preferida) de solucionar el problema es ajustar los permisos de activación del servicio COM predeterminados, lo que permite que las cuentas de usuario del Servicio de red (y posiblemente del Servicio local) activen la interfaz de devolución de llamada IVssWriter. Este método tiene la ventaja de solucionar el problema de forma permanente en un solo lugar y permitir que los servicios de VSS Writer se ejecuten con el nivel de privilegios previsto por Microsoft. Cualquier objeto COM al que se acceda (mediante un proceso que se ejecuta como servicio de red) aún puede imponer restricciones de seguridad.

Haga esta corrección haciendo lo siguiente:

  1. Haga clic en Inicio , luego seleccione Ejecutar .
  2. Escriba dcomcnfg . Este comando inicia la aplicación Servicios de componentes .
  3. En el panel izquierdo, vaya a Servicios de componentes -> Computadora -> Mi computadora .
  4. Haga clic derecho en Mi PC y seleccione propiedades.
  5. Cambie a la pestaña Seguridad COM , luego seleccione el botón Editar predeterminado en Permisos de acceso .
  6. Haga clic en Agregar... para agregar la cuenta "Servicio de red" a la lista de permisos.
  7. Asegúrese de que SOLO la casilla Acceso local esté marcada, luego haga clic en Aceptar .
  8. Cierre los servicios de componentes .
  9. Reinicia la computadora.
  10. Vuelva a ejecutar el plan de respaldo.
  • La segunda forma es ubicar los escritores de VSS (Inicio | Ejecutar | services.msc) que fallan y cambiar la cuenta con la que se ejecutan de Servicio de red a Sistema local. Luego, reinicie el proceso de servicio (o reinicie la computadora) y VSS Writer se ejecutará con privilegios máximos, eliminando así los errores de devolución de llamada de IVssWriter.

El posible problema de seguridad con este método es que el servicio se ejecutará con un nivel de acceso superior al previsto por Microsoft. Si el proceso VSS Writer es "pirateado", esto podría ser una debilidad de seguridad. Pero, si eso no le preocupa demasiado, repita este proceso para cada VSS Writer que genere un error 8194 y no debería experimentar más eventos de error en el funcionamiento normal.

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