SSL certificate issue detected (code 1007)

SSL certificate issue detected (code 1007)

Problemas con certificados

Situación

Un plan de copia de seguridad o restauración falló al iniciarse debido a que se detectó un problema con el certificado SSL en el host … mensaje de error:

Causa

El problema indica que el certificado SSL del proveedor de almacenamiento de copias de seguridad u otro punto de red relacionado con las copias está siendo rechazado en el lado del cliente. Las causas probables son las siguientes:

  • Sistema operativo

  • Actividad de software de seguridad

  • Configuración de la cuenta de usuario

Una vez que ocurre este problema, se debe llevar a cabo un conjunto de acciones para validar el certificado.


Resolución típica del problema

Solución 1

  1. Ejecuta la aplicación de Backup.
  2. En el menú de la aplicación, abre la cuenta de almacenamiento que se utiliza en el plan de copia que está fallando.
  3. Selecciona Configuración avanzada.
  4. Intenta listar los prefijos de copia de seguridad en ese almacenamiento abriendo un desplegable para iniciar la comunicación con el proveedor de almacenamiento en la nube.


  1. Aparecerá un aviso para aceptar el certificado SSL rechazado.
  2. Haz clic en Permitir.


Solución 2

Normalmente, los pasos de la Solución 1 son suficientes, pero si el problema persiste, procede de la siguiente manera:

  1. Accede a la carpeta Settings de la aplicación de Backup en la ruta:
    C:\ProgramData\COMPANYNAME\PRODUCTNAME
    (donde los nombres de empresa y producto se obtienen en el portal de Managed Backup -> Settings -> General -> Company / Product Name).

  2. En esta carpeta, elimina o renombra los siguientes archivos:
    CertificateExceptions.list
    serviceConfig.xml


  1. Vuelve a seguir los pasos de la Solución 1.

Solución 3

A veces, el rechazo del certificado puede estar causado por configuraciones específicas de firewall/software de seguridad que requieran una resolución siguiendo las instrucciones del sitio web del proveedor de dicho software de seguridad.
Como ejemplo, consulta la configuración de firewall de FortiGate.

Solución 4

El problema también puede deberse a la expiración de un certificado SSL en el lado del cliente, lo que puede resolverse mediante la renovación del certificado o la actualización del software (normalmente, gateway o firewall) que lo utiliza.
En casos específicos, también podría deberse a la expiración del certificado en el lado del proveedor de almacenamiento en la nube (suele ocurrir con proveedores de almacenamiento a pequeña escala compatibles con S3 o OpenStack).