Shadow Copy Is Missing (code 1712)

Shadow Copy Is Missing (code 1712)

Situación

Un plan de respaldo basado en imágenes finaliza con uno de los siguientes eventos:

  • Falta una instantánea (código 1712)

Causa

Este error se produce si el usuario o el sistema eliminan la instantánea debido a que no hay suficiente espacio en disco para las instantáneas en uno o más volúmenes del sistema operativo Windows durante la ejecución del plan de copia de seguridad. En algunos casos, las particiones del sistema provocan un aumento significativo del volumen de instantáneas. Para obtener más información sobre las instantáneas de VSS, consulte la sección Servicio de instantáneas de volumen en docs.microsoft.com .

Solución

Si el usuario elimina la instantánea, ejecute el plan de respaldo nuevamente. Si el sistema elimina la instantánea, use una de las siguientes soluciones.

Eliminar instantáneas antiguas. Para ello proceda de la siguiente manera:

  1. Abra un símbolo del sistema elevado ( cmd )
  2. En la consola cmd , ejecute el siguiente comando: vssadmin eliminar sombras/todos

Para obtener más información sobre el comando vssadmin , consulte la sección vssadmin en docs.microsoft.com.

Si el problema persiste después de eliminar instantáneas antiguas, deberá ampliar el almacenamiento disponible para instantáneas.

En un sistema operativo de servidor

Para resolver el problema de espacio de almacenamiento insuficiente en instancias que se ejecutan en el sistema operativo del servidor (Windows Server, etc.), proceda de la siguiente manera:

  1. Haga clic en Inicio y luego haga clic en Esta PC .
  2. En la sección Unidades y dispositivos , haga clic derecho en la unidad requerida.
  3. En el menú contextual, seleccione el elemento Configurar instantáneas....

  1. En el cuadro de propiedades de Instantáneas , vea la lista de volúmenes. Si la columna Usado está en blanco, significa que actualmente no hay espacio de almacenamiento asignado para instantáneas.

  1. Para asignar el espacio de almacenamiento para las instantáneas, seleccione el volumen de destino para las instantáneas y luego haga clic en Configuración .
  2. En el cuadro Área de almacenamiento , seleccione el volumen de destino para las instantáneas, luego especifique el límite de tamaño de las instantáneas o seleccione la opción Sin límite si desea mantener ilimitado el espacio de almacenamiento para las instantáneas.

Se recomienda asignar al menos el 30% del volumen a instantáneas. Para obtener más información, consulte el artículo Servicio de instantáneas de volumen en docs.microsoft.com.

  1. Una vez que haya terminado, haga clic en Aceptar y luego ejecute su plan de respaldo nuevamente para asegurarse de que el error no vuelva a ocurrir.

En un sistema operativo de escritorio

Para resolver el problema de espacio de almacenamiento insuficiente en instancias que se ejecutan en un sistema operativo de escritorio (Windows 7, 10, etc.), proceda de la siguiente manera:

  1. Abra un símbolo del sistema elevado ( cmd )
  2. En la consola cmd , ejecute el siguiente comando: vssadmin resize shadowstorage /on=x: /for=x: /maxsize=30%

El parámetro /on especifica el volumen de destino para el almacenamiento oculto. El parámetro /for es el volumen de origen del almacenamiento. El parámetro /maxsize especifica el tamaño máximo para el área de almacenamiento oculto en un volumen.

Se recomienda tener al menos un 30% de espacio disponible para instantáneas. Para obtener más información, consulte el artículo sobre cómo cambiar el tamaño de Shadowstorage de vssadmin en docs.microsoft.com.

    • Related Articles

    • Error de Vss (2417, 2418) - Shadow copy

      Tiempo de espera de confirmación de instantáneas (código 2418) Se aplica a: Windows Server 2008, Windows Server 2008 R2 Situación Un plan de copia de seguridad finaliza con el siguiente error: Tiempo de espera de confirmación de instantáneas El ...
    • An Error Occurred While Creating the Shadow Copy Provider COM Class (code 2415)

      Situación Un plan de copia de seguridad termina con el siguiente error: se produjo un error al crear la clase COM del proveedor de copia de la sombra El registro de eventos contiene la siguiente ID: 12292. Causa Este evento puede ser causado por ...
    • Access Denied. No Sufficient Permissions (code 2408)

      Acceso denegado. Sin permisos suficientes (código 2408) Situación Un plan de respaldo finaliza con el siguiente error: Access Denied. No Sufficient Permissions Los siguientes registros se encuentran en el registro de eventos: Error del servicio de ...
    • Too long Names (code 1620)

      Causa Algunos nombres de objetos en el origen de la copia de seguridad contienen nombres que superan las restricciones del proveedor de almacenamiento. Por lo general, la longitud del nombre del objeto está limitada a 1024 bytes. Solución Excluya los ...
    • Backup Storage Provider Returned Error (code 3017)

      Situación Un plan de copia de seguridad o restauración falló con el siguiente mensaje de error: El proveedor de almacenamiento de copia de seguridad devolvió el siguiente error... La causa raíz del problema se informa en el mensaje de error. Solución ...