Situación
Un backup basado en imagen falla con este error:
2020-01-01 10:00:00,000 [DiskBase] [1] ERROR - Start backup for disk 111111-2222-3333-4444-555555 \\?\Volume{222222-3333-4444-5555-666666} \\?\Volume{333333-4444-5555-6666-000000}
Alphaleonis.Win32.Vss.VssUnexpectedProviderErrorException
The provider returned an unexpected error code.
O bien en el log de eventos aparece este error:
VSS Error 01/01/2020 10:00:00 PM EventID: 22
Volume Shadow Copy Service error: A critical component required by the Volume Shadow Copy service is not registered. This might happened if an error occurred during Windows setup or during installation of a Shadow Copy provider. The error returned from...
Causa
Este error tiene varios motivos posibles, incluida la ausencia de un determinado componente VSS (escritor/solicitante) o el uso de un solicitante VSS de 32 bits en un sistema operativo Windows de 64 bits.
Solución
1. Abra la aplicación de copia de seguridad Catbackup o Beclone.
2. Asegúrese de que el Servicio de copia de seguridad se ejecute con la cuenta de administrador local.
3. En el menú Herramientas, haga clic en Cambiar cuenta de servicio y luego especifique las credenciales de la cuenta del administrador local.
4. Haga clic en Aceptar. El servicio de copia de seguridad se reiniciará automáticamente.
5. Cambie a la pestaña Planes de respaldo, luego edite el plan basado en imágenes que estaba fallando con este error
6. En el paso Seleccionar particiones, asegúrese de que la opción UseVSS esté habilitada para todas las particiones seleccionadas para la copia de seguridad.
7. Siga el asistente de copia de seguridad hasta el paso Opciones avanzadas, luego marque la casilla Usar proveedor de VSS del sistema.
8. Siga los pasos del asistente de copia de seguridad para guardar cambios. No ejecute el plan de copia de seguridad todavía.
9. Antes de ejecutar el plan de copia de seguridad, asegúrese de que se vuelvan a registrarse todos los componentes Core VSS en su instancia de origen. Para hacer esto:
Abra un símbolo del sistema elevado, luego ejecute los siguientes comandos:
Chdir "C: \ Archivos de programa \ Catbackup \ Backup en línea"
. \ cbb.exe fixvss -output completo
Espere la salida del comando y cierre la ventana del símbolo del sistema. *
*Si la ruta no existe, esto significa que la aplicación está instalada en una ubicación diferente en su sistema. Puede hacer clic con el botón derecho en el atajo de copia de seguridad en línea, luego seguir con la opción de ubicación del archivo abierto para averiguar la ruta para usar en su lugar.
Si el error persiste, contacte con soporte.