Error VSS. El sistema no puede encontrar el archivo especificado (código 1712)

Error VSS. El sistema no puede encontrar el archivo especificado (código 1712)

Error VSS. El sistema no puede encontrar el archivo especificado (código 1712)

Situación

Un plan de copia de seguridad basado en imágenes termina con el siguiente error: Error de VSS. El sistema no puede encontrar el archivo especificado

Además, en el registro de eventos de la aplicación se pueden encontrar los siguientes registros:

Log Name:      Application
Source:        VSS
Event ID:      12292
Level:         Error
Description:
Volume Shadow Copy Service error: Error creating the Shadow Copy Provider COM class with CLSID {65ee1dba-8ff4-4a58-ac1c-3470ee2f376a} [0x80080005].

Operation:
   Obtain a callable interface for this provider
   Obtaining provider management interface

Context:
   Provider ID: {b5946137-7b9f-4925-af80-51abd60b20d5}
   Class ID: {00000000-0000-0000-0000-000000000000}
   Snapshot Context: -1
   Provider ID: {b5946137-7b9f-4925-af80-51abd60b20d5}

Log Name:      Application
Source:        VSS
Event ID:      11
Level:         Error
Description:
Volume Shadow Copy Service information: The COM Server with CLSID {65ee1dba-8ff4-4a58-ac1c-3470ee2f376a} and name SW_PROV cannot be started. Most likely the CPU is under heavy load. [0x80080005]

Operation:
   Obtain a callable interface for this provider
   Obtaining provider management interface

Context:
   Provider ID: {b5946137-7b9f-4925-af80-51abd60b20d5}
   Class ID: {00000000-0000-0000-0000-000000000000}
   Snapshot Context: -1
   Provider ID: {b5946137-7b9f-4925-af80-51abd60b20d5}

Causa

Este error puede ocurrir si el valor de registro de ServiceDll para Swprv falta o es incorrecto.

Solución

  1. Ejecute regedit .
  2. Busque y haga clic en la siguiente clave de registro: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\swprv\Parameters

Si falta la clave de registro de Parámetros , realice los siguientes pasos:

Haga clic con el botón derecho en la clave de registro swprv , seleccione Nuevo , seleccione Clave , escriba Parámetros , luego presione Entrar

  1. Una vez seleccionada la clave de registro de parámetros , asegúrese de que el valor de registro de ServiceDll tenga el siguiente valor: %Systemroot%\System32\swprv.dll

Si falta el valor de registro de ServiceDll , realice los siguientes pasos:

  1. Haga clic con el botón derecho en la clave de registro Parámetros , seleccione Nuevo y luego seleccione Valor de cadena expandible
  2. Para el nombre del valor, escriba ServiceDll y luego presione Entrar .
  3. Haga doble clic en el valor del registro ServiceDll .
  4. En el cuadro Información del valor , escriba %Systemroot%\System32\swprv.dll y luego haga clic en Aceptar .
  1. Una vez que haya terminado, ejecute el plan de respaldo nuevamente.